A fix has been implemented for the unexpected Promotions folders appearing in Microsoft 365 mailboxes. We are currently monitoring the results to ensure the issue has been fully resolved. We will provide a final update once we have confirmed stability.
Monitoring
A fix has been implemented for the unexpected Promotions folders appearing in Microsoft 365 mailboxes. We are currently monitoring the results to ensure the issue has been fully resolved. We will provide a final update once we have confirmed stability.
Identified
We have identified the cause of the unexpected Promotions folders appearing in Microsoft 365 mailboxes and have stopped further creation of these folders.
Our engineering team is working on a fix and will post another update once it has been deployed.
Investigating
We are currently investigating reports of unexpected Promotions folders appearing in Microsoft 365 mailboxes. Our team is actively looking into this and we will provide updates as we learn more.